GNU/Linux

Opensuse Leap 15.0 Kendala VPN PPTP

June 7, 2018

Beberapa hari yang lalu saya melakukan upgrade dari opensuse leap 42.3 ke opensuse leap 15.0
Sebelumnya untuk service vpn menggunakan pptp masih bisa berjalan normal di opensuse leap 42.3 walaupun
harus melakukan modprobe conntrack pptp terlebih dahulu pada saat akan dial pptp.

Namun setelah upgrade ke opensuse leap 15.0 service pptp tidak berjalan seperti biasanya, sebagai perbandingan
di opensuse leap 42.3 versi pptp client yang digunakan adalah versi 1.7.2 sedangkan di opensuse leap 15.0 menggunakan
versi 1.8.0

Ternyata kendala dari permasalah tersebut adalah konfigurasi firewall, sebagai informasi tambahan bahwa opensuse leap versi sebelumnya yaitu leap 42.3 menggunakan SUSEfirewall2 sebagai firewallnya namun untuk opensuse leap 15.0 beralih menggunakan firewalld.

Untuk panduan enable service vpn pptp pada opensuse leap 15.0 bisa mengikut panduan dari komunitas opensuse indonesia berikut ini. Enable vpn pptp pada opnesuse leap 15.0

Owh iya, karena opensuse leap 15.0 sudah menggunakan firewalld maka saya sarankan service SUSEfirewall2 di-disable saja. Karena dari beberapa kejadian firewalld tidak autostart active pada saat habis reboot apabila SUSEfirewall2 masih enable.

Untuk melakukan disable SUSEfirewall2 ketikkan perintah :
~> sudo systemctl disable SuSEfirewall2.service

Selamat mencoba,
Salam opensource!

Please follow and like us:

Leave a Reply

Your email address will not be published. Required fields are marked *