Networking

Mikrotik Force DNS To OpenDNS Over Https Ports

March 1, 2019

This configuration shown how to force request DNS from local network to openDNS over https ports.
Please put this configuration on the top of other rules at firewall nat section.

/ip firewall nat
add action=dst-nat chain=dstnat comment=opendns22 disabled=no dst-port=53 protocol=tcp to-addresses=208.67.222.222 to-ports=443
add action=dst-nat chain=dstnat comment=opendns22 disabled=no dst-port=53 protocol=udp to-addresses=208.67.222.222 to-ports=443
add action=dst-nat chain=dstnat comment=opendns20 disabled=no dst-port=53 protocol=tcp to-addresses=208.67.220.220 to-ports=443
add action=dst-nat chain=dstnat comment=opendns20 disabled=no dst-port=53 protocol=udp to-addresses=208.67.220.220 to-ports=443

After apply above rule, please flush your machine DNS and do check on https://welcome.opendns.com/oops/ to make sure that you are already using openDNS.

Leave a Reply

Your email address will not be published. Required fields are marked *